Welcome To P8ntballer.com
The Home Of European Paintball
Sign Up & Join In

Geo 3.5 battery problem ???

NitroBall

SandStorm
Feb 20, 2006
2,878
571
148
99
Derby
problem started around mid season where new battery (always use Duracell Ultra or Energy paintball batteries) shows low on the screen or even flashing.
Played an event, got home to clean, and battery shows dead.
Got worse over the last couple months, and now Geo wont shoot due to showing dead battery.
God i must have gone through almost 20 batteries past 6 months, not sure what it is.
Have taken board out, inspected, everything is dry and clean, totally puzzled.
 

Tony Harrison

What is your beef with the Mac?
Mar 13, 2007
6,287
1,746
238
Do you have another marker or gadget you could check your Geo battery in? Or do you have a multitester to check the battery?

Have you cleaned the battery contacts in the gun?

If your batteries are working OK, it's pointing to a new board.

Have you set your gun to the suggested Winter Settings?
 

NitroBall

SandStorm
Feb 20, 2006
2,878
571
148
99
Derby
Do you have another marker or gadget you could check your Geo battery in? Or do you have a multitester to check the battery?

Have you cleaned the battery contacts in the gun?

If your batteries are working OK, it's pointing to a new board.

Have you set your gun to the suggested Winter Settings?
All boxes checked :(

Starting back playing this year, not having much luck with markers. At this rate, i'll be taking time out again :(

Will give planet a call and see if they can do anything .

Cheers Jono,