Welcome To P8ntballer.com
The Home Of European Paintball
Sign Up & Join In

Geo 2 - Help please

louisxg

Well-Known Member
Apr 30, 2015
154
25
48
29
Essex
Afternoon everyone!

I recently picked up a 2nd hand Geo 2 for my younger brother as I also own a Geo 2 and he is a big fan. Managed to pick him up recently and took it to walk on and....unfortunately we are having a big issue with it. Unfortunately I am still fairly new to paint ball so my technical knowledge isn't amazing.

The marker powers up no problem but when you fire it will fire maybe 2 - 5 shots and then all the paint just gets jammed in the barrel. It feels as if there isn't enough pressure coming from the bolt to push the paint through. Also I am not sure if it is linked but when we got the gun chrono'd the readings were all over the place and wasn't consistent. So far I have:

Replaced the batteries in the hopper.

Took the bolt out, cleaned it up, relubed it etc.

Taken the reg apart and cleaned it etc.

Made sure the barrel and everything else was clean etc.

But STILL having the same issue. The 1st few shots are perfect and then it just jams up in the barrel. What could be the problem and what can I do to solve it guys?

Thank you for taking the time to read this post everyone :)
 

louisxg

Well-Known Member
Apr 30, 2015
154
25
48
29
Essex
First of all what type of battery is in the marker?

is the dwell on standard setting?
I have just looked at your pinned post and although it is a Duracell battery it isn't a procell one so I will order a new battery.

How do i adjust the dwell/standard settings? I am a noob haha. I will see what mode it is on if you can assist - thank you :)